Helicon Focus 8

Focus Stacking
  Rendering
  Preview
  Retouching
  Text/Scale Bar
  Saving Results
Micro Panorama
  Micro Panorama Parameters
  Shooting Micro Panorama
Program Preferences
  General
  Autoadjustments
  Performance
  Integration
Advanced functionality
  Processing of Raw files
  Raw development settings
  Batch process and Split stacks
  Folder monitor
  Dust Map
  Command Line Mode
Licensing
System Requirements
Install/Uninstall
  Installation for Windows
  Installation for Mac OS
Integration
  Adobe Lightroom
  Helicon Remote
  Helicon 3D Viewer
Shortcuts
Samples

The latest version of Helicon Focus Help is available on our website.

You may also watch Video tutorials covering the main how-to's and features.

FOCUS STACKING

Helicon Focus is a software for focus stacking and micro panorama stitching. No matter if you are an amateur making first steps in photography or a laboratory scientist using state-of-the-art optics, you will be impressed by how easily and smartly Helicon Focus meets any challenge.

This software is a unique focus stacking tool allowing to achieve images with theoretically unlimited depth of field. It means that if you have a number of partially focused photos - a stack - the program will render it into a fully focused image by combining the sharpest areas from each photo of the stack.

If you are new to focus stacking, first we suggest you to watch video tutorials available on our website.

Rendering

The main work screen has four tabs that one by one will lead you from opening of source images to saving of the output one.

rendering tab

The Rendering tab is the starting point and the main workspace in Helicon Focus. Here you open source files, set the focus stacking parameters, launch rendering and preview the results.

1 - Menu bar

2 - Toolbar

3 - Workspace tabs

4 - Source images

5 - Render parameters

6 - Output images

7 - Zoom controls

8 - Current source image

(can be top or left)

9 - Current output image

(bottom or right)


 

Preview

Preview is a new feature that has been intoduced in Helicon Focus v.8.

It's often needed to try different rendering methods and parameters to find the combination that works best for the stack. Preview will help comparing the results in real-time mode.

Preview mode: workflow

  1. Open images in Helicon Focus.
  2. Press the previewbutton to open Preview window.
  3. Select Preview size.
  4. Higher resolution of the review image will allow to preserve more details, but may decrease refresh time.

  5. Switch between rendering methods, experiment with Radius and Smoothing, with sorting order to see the effect this has on the output.
  6. Once you have chosen the optimal set of parameters for this stack, hit Render.

Autoadjustments

You can experiment with alignment parameters in realtime mode, check how the output will look if cropped.

Stack browser

The cornerstone for achieving good rendering result is the quality of the stack.

Unfold Stack browser panel and drag the slider to quickly browse through the stack. This will allow to check

Show adjusted

When unchecked, the source images will be displayed during browsing through the stack the way they have been shot, reflecting the misalignment and displacement that took place.

If the Show adjusted option is checked, adjustment parameters will be applied to source images when you browse, i.e. you will be able to see how the program will cope with the existing misalignment and displacement.


 

Source Files

Opening Source Files

There are several ways to open source files:

Now the Source images list shows which files will be processed (stacked) once you press the renderRender button. The list of source images will be updated each time you choose another output image, showing the files that were used to render this result.

The Source images list has a context menu that can be called by right-clicking on any of the images on the list or by pressing the menu button. This menu gives you several options:

Removing Source Files

To remove one or more files from the Source images list, select one or multiple images holding down the Ctrl key. Then right-click on one of the highlighted files to call the context menu and choose the Remove image option. You can also click the Remove image button right below the Source images list or just press Del.

Please note that removing images from the list doesn't delete the files from the disk.


 

Rendering Methods

You can choose between three focus stacking methods: methods A, B, and C.

Method Bl (B legacy) is not on the main list, but can be enabled in Program preferences.

Here's a brief explanation of each method and its most typical applications:

Although it's your personal experience that will be your guide in choosing the right rendering method, we will give you some practical tips in the table below.

Method A
Method B
Method C
Multiple crossing lines, complex shapes
+
-
+ +
Images with a glare
+
+ +
-
Long stack
(> 100 images)
-
+
+ +
Non-consecutive (random) order of images
+
-
+
Preserving color and contrast as a priority
+ +
+ +
+

Although method C can cope with some stacks shot in non-consecutive order, we still strongly recommend to shoot images in correct order, i.e. either from fore- to background or vice versa. Right shooting order is one of the preconditions for good focus stacking results.

Selection of the most suitable method depends on the complexity of the stack, the number of images and other factors. So there can't be any strict rule as for the optimal choice, and we do recommend you to try all of them.


 

Radius

The Radius parameter is one of the two main controls to be adjusted, it is only available in A and B methods.

When performing focus stacking the program analyses each pixel of the source image in order to define if it is in focus. Then the detected focused areas from the whole stack are combined into one output image. Radius is the control that sets the size of the analysed area around each pixel.

We recommend you to try setting different values. Start with the default value and then set it to the minimum to see what happens. Then, gradually increase the value to remove noise, unwanted artifacts, or halos along the edges. If your image has fine details and thin lines - which is true for most images - a low radius of about 3-5 will likely produce the best results, even though this may cause more noise or halo effects.

Preview mode can be very helpful for understanding the changes this parameters makes.

In order to get some more practical understanding of this parameter, let's consider two most typical cases.

The first one is the image with fine intersecting details (close-ups of insects, fur, bristles etc.). Here the smaller the value of the Radius is, the sharper the intersecting details are. On the other hand, you should keep in mind that there might also be artifacts on smooth, solid-color surfaces, so you need to find a balance.

Here are two stacking results rendered at a different radius, both by B method.

 

Method B, Radius = 1 Method B, Radius = 22

Another quite typical example will show the advantages of higher Radius values - minimizing halo or other artifacts along the object edges. As you can see from the photos below, increasing radius allows to almost eliminate the halo effect. Excessive increase of the Radius value will affect details.

Method B, Radius = 2 Method B, Radius = 22

Experiment with your stacks, compare results to find the balance.


 

Smoothing

Smoothing is the second of the two main focus stacking parameters. When analysing the stack, the program detects the most sharp focused areas of source images to combine into one output image.

For methods A and C smoothing determines how these sharp areas will be combined. Low smoothing produces a sharper image, but the transition areas may have some artifacts. Setting a high smoothing value may result in a slightly blurry image, though without any visible transition areas.

For method B this value determines how the depth map will be smoothed out.

Try experimenting with smoothing parameter in Preview mode to see the changes that take place.

Note: in order to reset controls to default, right-click on the slider of the parameter you want to reset. This works for all controls in Helicon Focus.


 

Outputs List

Once you press the Render button the stack processing starts. All resulting images and processing progress bars will appear in the Outputs window at the bottom of the screen. Here you will find all the results produced during this working session. Select the output, and the source images that were used to render this result will be displayed in the Source images list. The Outputs window also contains brief info on the stacking parameters: method - radius - smoothing.


 

Retouching

retouching tab

In some cases you will need to do some retouching of the output image. On the Retouching tab we have three main brushes - Copy from source, Clone and Erase. You can choose the brush in the right part of the tab.

Copy from source

Both images will appear to you perfectly synchronized, even when zooming in or out. The output image will be displayed on the right.

If you already tried to shoot a nice stack yourself, you know that it can be quite challenging due to a range of external factors affecting the shooting process. So sometimes you will have blurring, banding, halo or other artifacts. Many of them can be fixed with the Copy from source brush. The idea of this tool is that it will allow to replace artifacts on the output image by copying the same area from the relevant source image.

On the left - one of the source images, on the right - the output image right after rendering (the antennae were moving during shooting, so the program displayed antennae from all the source images on the resulting one).

In order to copy the area from the source image to the output one, choose the Copy from source brush, pick the image in the source images list, i.e. select the image where the area to be retouched looks better than on the other ones. Then adjust the brush parameters and hold down the left mouse button to paint.

On the left - one of the source images to copy from, on the right - the output image with Copy from source brush applied.

You can choose the source image you need manually, by going over the list in the Source image window. But there's also another option, which is especially relevant for long stacks. Position the brush on any part of the output image and you will see the name of the file it was taken from. Press F9 key and this source image will be immediately loaded to the left window.

Use Page Up and Page Down keys to navigate through the source images list.

Each rendering method has its advantages and works better for different parts of the image. Sometimes in order to get perfect result you need to combine parts of the output images rendered by different methods and rendering parameters. To do this, press the Use another output as a source button below the Source images list to choose one of the output images that will serve as a source one. This feature is only available in Pro version.


 

Brush Parameters

There are four main brush parameters:

Brush size - sets the diameter of the copied area. Minimize it for more fine and precise strokes.

Brush hardness - sets the hardness/softness of the brush edges. With high values the brush stroke will have sharper edges, with lower ones the copied element will blend better into the target image.

Color tolerance - makes the brush "smart". When set to 100% it will allow to copy all (100%) pixels in the painted area, while setting to lower values will make the brush pick pixels to be copied by their color - only those pixels will be copied that have color similar to the central pixel of the brush spot. For instance, this option becomes truly useful when it comes to dealing with fine details or complex outlines that you need to leave as is while copying the background.

This simple example will show you how it works:

Color tolerance set to low value - the brush is applied only to yellow background, leaving pencils in the foreground intact.

NB: Brightness was set to a high value just to make it more demonstrative.

Color tolerance set to maximum - brush is applied to all pixels within the copied area.

Brightness - makes copied pixels either brighter or darker to match the brightness of the output image.

Check the Show source map option to highlight the part of the current source image that was used in the output one.

For more convenience of precise and fine retouching of 100% scale high-resolution image, use the Grid feature. The Ctrl+G shortcut will show/hide the grid that will serve as a reference helping you navigate within the zoomed image.

Show depth map option allows to display the depth map of the output image during retouching.

Cloning

The second brush type allows to clone fragments within the output image. Choose the Clone brush and one of the options: Clone area or Paint with pattern.

With Clone area brush the source and the target cloning areas are moving in parallel, while the Paint with pattern picks the source spot and allows to clone it to any target area.

The example below show the difference between the Clone brush types.

The first is the Clone area brush with default brush parameters. As you can see, the parallel movement of the source and the target areas enables to actually clone any element within the output image.

Image: Asian Lily ©Walt Polley

Next brush type is Paint with pattern. This one allows to choose the pattern on the output image and to paint the target area.

Image: Asian Lily ©Walt Polley

The Texture only option allows cloning the texture and leaving the background color intact rather than copying the part of the image completely,.

You can also visit our Video tutorials page to see these brushes in action.

Eraser

In order to cancel the unwanted changes, use Undo buttons to undo a point, a stroke or a brush.

But sometimes it is more convenient to use the Eraser. Adjust the brush settings just as you did with other retouching brushes and go over the parts of the image that you want to be back to initial state.

Retouching in several sessions

If you want to close the program and continue retouching the image later, you can save the project file and get back to it some other time. This saving option will keep all the changes that were made to the source images and the output one, including all the adjustments and retouching history, so that you can even undo the changes during the next retouching session.

To use this option go to the main menu->File->Save project file... Choose the folder, and all the necessary info will be saved to the *.hproj file.

To continue working with this project go to the main menu->File->Load project file...


 

Text/Scale

text tab

On the Text/Scale tab you can add a scale bar and one or several lines of text to your image.

 

Adding Text

Check the Text box to add or remove text from the image. Once it is checked, you can type the text that you want to be written on the image in the Text window.

The Insert special menu allows to insert special symbols (© and µ) and image metadata, such as date, time, aperture, ISO, etc.

The font can be selected from the Font list.

decr incr buttons change the font size; bold italic underline buttons change the text style; the color picker allows to set the font color.

The drop down box below allows to choose the text effects: highlighted, shadowed, embossed paper or no effect.

Use left right buttons to align the text.

The Transparency sets the opacity of the text.

To add one or several more lines of text, click on the Add button.

To delete all text from the image, click the Delete all button.

To edit existing text, first click on it (selection will be marked with a green rectangle) and then edit its contents or properties.

 

Adding Scale Bar

Adding a Scale bar will be helpful when it's difficult to understand the dimensions of the object on the image without any reference.

To add a scale bar to your image, check the Scale check box.

To select the appearance of the scale bar, click on the Select Scale... button and choose one of the offered images.

You can also add your own scale bar type by clicking on add in the Select Scale window and locating the image to be opened. The scale bars are typically black and white. To invert colors, check the Invert colors check box.

The Scale width shows scale size against the image width. This value can be used to calibrate the scale using objects of known size.

Typically, the scale calibration process will look like this:

1. Shoot a stack of an object of known size. It can be a stack consisting of at least two images. For example, a regular school ruler can be taken as a reference object.

2. Render this short stack, go to Text/Scale tab, check the Scale check box, choose the scale bar type and stretch it to match the known dimension. This will define the correspondence of real life dimensions to the Scale bar width in %.

3. Resize the scale bar proportionally, depending on what scale bar length you need for the further reference.

Now you can add this scale to other images to provide some reference.

Of course, this workflow is only applicable for images made in identical shooting conditions (the same lens, focus, camera position).


 

Saving

saving tab

On the "Saving" tab you can save or export the resulting image.

Save... Allows to save the resulting image in JPEG, TIFF or DNG format. The default name of the file is formed automatically.
Export 3D Model Creates a 3D model and opens it in Helicon 3D Viewer; here you can adjust the model and save it in a variety of formats.
Create Animation Creates an HTML page with JavaScript animation of the stacking process.
Save Depth Map Saves depth map as a grayscale image. This image can be used for relief measurements or for 3D modelling.
Export Layers Saves aligned layers as semitransparent PNG/TIFF files. The transparency is set in a way for the layers to produce the output image if opened in Photoshop. PNG and TIFF options are completely different and produce different results. TIFF is based on source map, while PNG is based on depth map. If you are not sure, we'd recommend trying both options and choosing the one that suits your application better.
Copy Result to Clipboard Allows to copy the resulting image to clipboard.
Publish to Web Automatically converts, resizes for the web and uploads your image to Helicon Soft secure server with just one click. You will also get a unique URL that you can immediately send to anybody to share your image.
Share on Facebook Resize the image if needed, add a description and post directly to your Facebook page.
Save Project file Save the image in the current state to be able to continue retouching and working with it later.

 


 

MICRO PANORAMA

Please note that the micro panorama function is only available in Pro version. 

The micro panorama function is designed to stitch images made through a microscope. It may fail to stitch images that were made by camera rotation on the tripod.

The program aligns images based on the Panorama autoadjustment settings (main menu->Edit->Preferences->Autoadjustments). The program only shifts images to align them, no magnification or rotation is applied.

Micro Panorama Parameters

The Rows control sets the number of rows in your panorama.

The Columns control sets the number of columns in your panorama.

The Overlapping of rows sets the overlapping value of adjacent rows. Move the slider until you see the pattern on the images fit.

The Overlapping of columns determines how adjacent columns overlap. The images can also be moved manually, dragged with a mouse which sometimes allows for more precise alignment of images.

The Seam smoothing sets the width of seams with gradient transparency.

Check the Crop margins box to crop the resulting panorama in a way to remove the blank spaces formed after shifting of its elements.

With Shooting order parameter you set the order in which the images of panorama were shot. There are two ways to shoot panorama: each row from left to right, or odd rows (1,3,5,...) from left to right and even rows (2,4,6,...) in the reverse direction. And in any case rows should be shot in consecutive order, i.e. the 1st, the 2nd, the 3rd etc.

The Reset positions button allows to restore the original position of images after you dragged them with mouse.

The Reset will restore the default values of panorama settings.


 

Shooting Micro Panorama


 

PROGRAM PREFERENCES

To open the Preferences dialogue, go to the main menu->Edit->Preferences.

General

Mouse dragging speed - sets correlation between movement of the mouse and shifting of the image. It makes navigation in the main window faster, especially when working with zoomed images.

Magnifying glass size - defines the size of the virtual magnifying glass that appears if you left-click on the image.

Monitor profile is used to display images on the monitor. Your monitor has its own color profile that was saved to the system folder during monitor installation. Helicon Focus will pull up the relevant default monitor color profile, but you can set an alternate one if you wish.

Show intermediary results during calculation - enables screen updating during processing. Please note that it will add another 30% to total processing time!

Automatically check for program updates - if enabled, the program will check for updates by connecting to Helicon Soft server each time when started.

Show legacy B method - method B in Helicon Focus 7 has been significantly changed. The legacy method B (i.e. the one used in earlier versions) is hidden by default, but checking this option in Preferences will make it available. Legacy method B allows for faster processing, however it may produce more artifacts on uniform background, especially if images of the stack have different brightness levels.

DPI in the output image - sets how much DPI you want to have in the output image.

Save file name template - sets the file naming pattern. You can add additional parameters from the dropdown menu.

Do not save EXIF metadata - remove the metadata of the output image.

Use default jpeg quality - if checked, the program will always save jpeg's at default quality, without asking confirmation each time before saving.

Autoadjustments

Focus Stacking Autoadjustments

Even if you shoot a stack from a tripod and the subject is completely still, the images in the stack will not be perfectly aligned. It means that even with good shooting conditions, the subject will slightly change its size and position on the image every time the focus is shifted. So during focus stacking the program has to somewhat scale and sometimes rotate and shift images in order to align. This group of controls allows to fine-tune the alignment properties if needed.

Adjust vertically - sets maximum vertical shift between two consecutive images of the stack in % of their width or length, whichever is greater.

Adjust horizontally - defines maximum horizontal shift between two consecutive images in % of their width or length, whichever is greater.

Rotate - defines maximum angle between two consecutive images in degrees. Usually not needed for microscope and tripod shots.

Scale - defines maximum difference in subject size between two consecutive images in % of their width or length, whichever is greater.

Autoadjustments interpolation - allows to choose the interpolation principle. Slow methods preserve details better, though it is hardly noticeable.

Adjust brightness - defines whether brightness of consecutive images should be equalized.

Manual focus detection area adjustment - shows a blue rectangle of selection area and allows the user to adjust the area of alignment of frames in the stack. This option may be useful, for instance, if the frames have been shot through a microscope and black edges on images do not allow to align the stack correctly.

Crop result image automatically - the program may be lacking data at the image edges for alignment of frames in the stack. Normally it results in stripes on the resulting image and other artifacts. This option allows to crop the areas lacking data automatically.

Show user crop rectangle - shows a dotted border rectangle allowing the user to select cropping area for the entire stack.

 

Panorama Autoadjustments

Group of settings related to processing of the panorama stack.

Adjust vertically - defines maximum vertical shift between two consecutive images in % of their width.

Adjust horizontally - defines maximum horizontal shift between two consecutive images in % of their width.

Depth map feathering - the degree of smoothing of the depth map used in method B.

Performance

Disk cache folder sets the path to the folder used for storage of temporary files (TIFFs from loaded Raw files, the retouched image). The cache is cleared when the program quits; if it fails to clear cache on exit, it will try to do it during the next startup.

Memory cache limit - sets the share of RAM that the program can use for storage of the most recently used images. Normally it would increase the speed of repeat processing significantly.

Parallel image loading - enables upload of images in multiple streams. Speeds up processing of jpegs and Raw files on SSDs, but may slow down processing if applied on other types of drives and/or with TIFFs.

Use OpenCL hardware acceleration - Helicon Focus (Pro version) can use performance capabilities of the graphics processing unit (GPU) to speed up calculations. You can select the device from the drop-down list, restart Helicon Focus and compare the performance results with Run Benchmark feature. We recommend 4GB graphics processing units for 20-40 megapixels image processing. If your device has not been detected or is unstable, we recommend to update your GPU drivers. You can compare the performance results of different hardware on the Performance Benchmarks page.

Fail safe mode - this option could help if activating OpenCL results in issues. You should not turn it on unless specifically suggested by the support team. If you're having a problem with OpenCL, contact support for help.

Run benchmark - starts processing of 100 frames by method B. Test result can then be compared to the results of other users (by clicking the 'Compare' button in the results window). This can be useful for evaluating your current hardware and/or choosing new one.

Integration tab

The path to Helicon Focus plug-in for Lightroom is set on the Integration tab of the Preferences menu.

You may need it if you have several versions of Lightroom installed on your computer or you have problems with running LR-HF export. If so, please make sure that the plug-in was installed to the right Lightroom folder.

You may need to install or update Adobe DNG Converter for processing of Raw files. If the Converter has been installed to a folder different from the default one, please set the path to Converter on the Integration tab.


 

ADVANCED FUNCTIONALITY

Processing of Raw files

With Helicon Focus you can process Raw files opening them directly in the program or exporting from Photoshop Lightroom or Capture One.

With Helicon Focus Lite license you can open Raw files and save the output to .jpg or .tif.

Helicon Focus Pro license enables Raw-in-DNG-out mode - here you can find a comparison chart demonstrating the difference between standard Raw processing workflow and Raw-in-DNG-out mode.

With Helicon Focus Pro you will have this mode enabled automatically - you will be able to open Raw files, process the stack and save the output to .dng.

Once you open Raw files in Helicon Focus, you will see the Raw development settings button appear beneath the Source images window in the right part of the screen.

If for one reason or another, you do not see .dng among file type options on the Saving tab, please

a. make sure you have been processing raw files. Saving the output to .dng is not possible if the source files were of .jpeg or .tiff format

b. make sure you have the latest version of Adobe DNG Converter installed

c. if you have changed the default folder when installing the Converter, set the path on the Integration tab

d. select Raw-in-DNG-out loader codec in the Raw development settings beneath the source images list.

If you export Raw files from Photoshop Lightroom for further processing in Helicon Focus and saving to .dng, please watch the Helicon Focus - Raw-in-DNG-out mode video.

Raw development settings

Helicon Focus allows for processing of a variety of file formats, including development of Raw files. Once you open the Raw source image, Raw development settings button will appear beneath the Source images list. It enables more precise adjustment of raw stack processing parameters.

Codec: DCRaw is used by default, but there's also an option to choose the codec yourself, install WIC codecs (Windows only). The only option allowing to save the output to .dng (Helicon Focus Pro only feature) is Raw-in-DNG-out loader.

White balance (dcraw): when selecting built-in dcraw codec, you can choose if you prefer Helicon Focus to set the white balance automatically or to use the white balance settings as set when shooting.

Highlights (dcraw): choose the highlight recovery mode - Clip (clips highlights to increase contrast), Unclip (leaves highlights unclipped, may give a pink hue), Blend (blends clipped and unclipped values), Rebuild (reconstructs overexposed areas from the adjacent properly exposed ones).

Interpolation (dcraw): choose the demosaicing algorithm - Linear (basic, but fast), VNG (Variable Number of Gradients), PPG (Patterned Pixel Grouping), AHD (Adaptive Homogeneity-Directed), DCB.

Color space: choose the color space that determines the range of colors, tones, brightness of the image - Raw, sRGB (the smallest range of colors and tones, but the most commonly used), Adobe (wider color range, though not supported by some browsers and requiring special software to reproduce the colors correctly), ProPhoto (the widest range of colors, 16-bit processing recommended).

Noise threshold (dcraw): the higher the noise threshold value, the more noise is removed, though the more details might be lost. Normally optimal values are between 100 and 1000.


 

Batch process and Split stacks

This feature allows to optimize and speed up multiple stack processing. All Helicon Focus licenses allow adding several stacks one by one, loading each of them to the source images list and setting rendering parameters for each stack. Batch process being a part of Pro functionality allows loading multiple stacks at a time and adjusting parameters for each one or for all of them for further rendering.

If you have several stacks in one folder, it is usually time-consuming to sort the whole pile of images into separate stacks. And sometimes it may even be quite problematic to make it, especially if you were shooting the same subject several times with slight difference in settings. Helicon Focus can split images into stacks automatically, please find the detailed instructions below.

Batch process:

  1. Open Batch process window: Helicon Focus main menu->File->Batch process..., or F7.
  2. Add images, folder or several folders. Add current sources option will add all the images from the current source images list as a separate stack - this is the way you can add images exported from Lightroom to batch mode.
  3. Set rendering parameters - method, radius, smoothing.
  4. Adjust Autosave settings - choose the output image format, quality and target folder.
  5. Press Render button to start processing.

The dropdown list at the end of each table row will open a small pop-up menu, allowing to Remove the stack (just from the list, not from the disk), to Apply current rendering parameters to all other stacks and to Split stacks.

 

Split stacks:

  1. Open Batch process window: main menu->File->Batch process..., or F7.
  2. Add the folder to be split.
  3. Choose Split stack in the dropdown menu.
  4. Adjust the parameters - choose if you want stacks to be split by number of images, by minimum time interval between shots, by exposure or by focus. Please find more detail below.
  5. The last line will give you the summary of how many stacks you'll get with these splitting parameters.

  6. Press the Split button.
  7. Proceed as with other stacks in batch mode dialog window.

Split by image count - will be useful if you have several stacks of equal number of images.

Overlapping: when working with long stacks retouching may become easier if the long stack is first split into substacks. Substacks will be processed in batch mode and can then be merged into a single image. For ease of retouching we recommend that stacks overlap by 10-15%.

For instance, if you have a stack of 200 images, it can be challenging to pick the right image to copy from during retouching. In cases like that you can split this long stack into 20 substacks of 10 images each with overlap of 1-2 images. Once the substacks are rendered in batch mode, you can process 20 outputs to receive a single image. It will be much easier to pick 1 out of 20 images for retouching than 1 out of 200.

Split by time - will be helpful if you do not know the exact number of images in stacks, but know the minimum time interval between shooting sessions.

Split by exposure - this splitting method is used for a specific shooting mode. If you were shooting stacks using Helicon Remote which allows exposure bracketing, go for Split by exposure and it will make all the sorting for you.

Split by focus - splitting method for HDR mode, where several shots are made for each focus position.

No matter which method you choose, the images will be split into stacks only virtually for further processing in Helicon Focus, no actual folders with stacks will be created on the disk.


 

Folder monitor

Helicon Focus can monitor the specified folder and process the stack automatically once all the images of the stack are uploaded.

To use the Folder monitor option, go to main menu->File->Folder monitor, or use a shortcut: Alt+Shift+Ctrl+M.

File types to process - 'JPEG/TIFF then Raw' means that if you have been shooting JPEG+Raw, the program will form two separate stacks.

Time between shots to split into stacks - sets the time interval for the program to determine the end of one stack and the beginning of the other one.

Process existing files - if not checked, only the files added after launching the folder monitoring will be processed.

Show Preview option opens a list of existing stacks in the monitored folder.

Copy files before processing - allows to copy files and to split them into separate folders before processing. This will allow preventing the folder with new files from overfilling.

Autosave results - the output can be saved to a specific folder and in a chosen format.

Once the Folder monitor is launched, you will see it running in the right part of the toolbar.


 

Dust map

If there are dust particles on the camera sensor or in the optical system of the microscope, it will result in black dots on every image you shoot. Even if usually it does not bother you too much, when it comes to focus stacking of such images, these spots will turn into dark traces on the output image. Helicon Focus has a solution for such stacks - the Dust map function. Basically, you need to provide the program with a sort of a "map" of all dust particles that will be applied to the whole stack in order to eliminate these dust imprints. This function works for hot pixels as well.

Below is 100% crop of the sample image provided by Phil McCollum demonstrating how the output image looks like with and without a dust map:

Dust map function is OFF. Move the cursor over the image to see how the dust map function works.

To use the Dust map feature, please follow these steps:

  1. Prepare a dust map: when shooting your images, make one unfocused (!) shot of a white surface, so that dust on the sensor can be easily identified.
  2. Launch Helicon Focus, add stack of images.
  3. Go to main menu->File->Set dust map... Once added, the name of the dust map file will be mentioned beneath the Source images list.
  4. Start rendering.

Please note that dust map should have the same dimensions as all the other images in the stack.

Here is an example of the dust map (provided by Phil McCollum):

In order to remove the dust map, go to the main menu\File\Remove dust map, or press the menu button next to the dust map file name.


 

Command line mode

Helicon Focus can be called from other programs using command line parameters.

Command line parameter Description
   
-silent Starts Helicon Focus without interface, with progress bar only
--activationCode 12345678 Registers the license automatically
--register-global Registers the license for all users on this computer (requires admin rights)
-save:full_name.ext Saves result to the full_name.ext. If omitted, result is saved to Focused subfolder
-j:jpeg_quality Sets JPEG quality (0-100)
-dmap Saves depth map image
-noresult Do not save resulting image
-3d Saves 3D model in Helicon 3D Viewer file format
-noprogress Do not show rendering progress bar
-i full_name.ext full_name.ext points to text file with input file names separated with a new line
-o full_name.ext full_name.ext points to text file to store list of saved outputs
-preferred-output-path folder_name folder_name - folder to be opened by default when saving outputs from Helicon Focus
-tif:x Specifies TIFF compression option: 'lzw' or 'u' for LZW compression or no compression, respectively. If this option is omitted, LZW compression is selected. Example: -tif:u
-project: Saves project file
-dustmap: Opens dust map file
-mp:x Sets Method (0=method A, 1=method B, 2=method C)
-rp:xxx Sets Radius
-sp:xxx Sets Smoothing
-va:xxx Sets Vertical shift adjustment
-ha:xxx Sets Horizontal shift adjustment
-ra:xxx Sets Rotation adjustment
-ma:xxx Sets Magnification adjustment
-ba:xxx Sets Brightness adjustment
-im:x Sets Interpolation method (1=Bilinear,...)
-dmf:xx Sets Depth map feathering

 

Examples Description
   
HeliconFocus.exe -silent "c:\my images\set20" Process all images in "c:\my images\set20" folder with default parameters
"C:\Program Files\Helicon Focus\HeliconFocus.exe" -silent . Process all images in the current folder and save result to "Focused" subfolder
HeliconFocus.exe -silent "c:\my images\set20" -rp:6 -sp:7 -mp:1 Process images with Radius set to 6 and Smoothing set to 7
HeliconFocus.exe -silent "c:\my images\set20" -save:c:\result.tiff Process images in "c:\my images\set20" folder and save as tiff file to c:\

 

LICENSING

Helicon Focus is a shareware program. You can evaluate a fully functional version for 30 days. Once the trial period is over, the program will add promotional text to the resulting image and will limit its resolution to 4Mpixels unless you register the program.

To register the program, buy a license and get a registration key by email. There are three Helicon Focus license options: Helicon Focus Lite, Helicon Focus Pro, and Helicon Focus Premium.

A registered copy of Helicon Focus may be installed on up to four computers, as long as only one copy is used at the same time. A single license allows for unlimited hardware upgrades and/or transfers to other computers.

Helicon Focus Lite

Helicon Focus Pro

Includes all the features of the Lite version, plus:

Helicon Focus Premium

Includes all the features of the Pro version, plus:


 

SYSTEM REQUIREMENTS

The recommended system configuration is:

Minimum system requirements are:


 

INSTALL/UNINSTALL

Installation for MS Windows

The latest version of Helicon Focus is always available on the Downloads page of our website, if your license allows updating.

To install Helicon Focus:

1. Go to Downloads page.

2. Hit the Download button

4. Run the .exe file.

5. Follow the installation instructions.

6. Launch Helicon Focus from the Start menu or the desktop shortcut.

You can uninstall the program from the Control Panel.

Installation for Mac OS

The latest version of Helicon Focus is always available on the Downloads page of our website.

To install Helicon Focus:

1. Go to Downloads page.

2. Hit the Download button

4. Open/mount the .dmg file from the Downloads folder.

5. Drag the Helicon Focus and Helicon 3D Viewer icons onto the Applications folder icon.

6. Launch Helicon Focus from the Applications folder.

You can uninstall the program from the Applications folder.


 

INTEGRATION

Adobe Lightroom

Helicon Focus plug-in for Lightroom enables smooth and simple interaction between these two programs. The plug-in is installed automatically.

In order to export images from Lightroom for further processing in Helicon Focus, please follow this algorithm:

  1. Launch Photoshop Lightroom.
  2. Select images you want to be rendered.
  3. Export to Helicon Focus. Call the context menu with a right-click on any of the selected images, open Export and select one of the export options. Helicon Focus will be opened automatically, exported images will appear on the Source images list.
  4. Render the stack in Helicon Focus. Adjust the processing parameters and start rendering. The resulting image icon will appear in the Output images menu in the bottom right-hand corner. If you find that the resulting image needs some retouching or you want to add text/scale, go to the relevant tab.
  5. Save output image. Once you feel like stacking is done and you are happy with the result, go to the Saving tab, hit the Save button and choose the folder, the file type and name.
  6. Close Helicon Focus. The resulting image will be imported back to Lightroom automatically.

Once you start exporting source images to Helicon Focus, you will see that an export progress bar will appear in Lightroom. The process will be shown as suspended until you close Helicon Focus, since Lightroom considers rendering in Helicon Focus as a part of export process.

Please note that the saved output will only be imported back to Lightroom after you close Helicon Focus window.

Export options

Lightroom exports images to Helicon Focus in TIFF, JPG, DNG and original format.

If you export as TIFF or DNG, use the relevant export preset:

In order to export in a different format follow these steps:

  1. Right-click any image in Lightroom and select Export -> Export... in the context menu:
  2. Go to Helicon Focus tab -> File settings. Select the 'Image format'.
  3. Click 'Export' button.

If you use the same export parameters for your stacks, set them up once and use 'Export with Previous' option.

If you have problems exporting from Lightroom, try to re-install the plug-in: go to main menu->Edit->Preferences...->Integration tab and click on 'Uninstall plug-in' and then on 'Install plug-in'.

If this doesn't solve the issue, please contact our Support team.

Please watch the video tutorials on our website for more details.

Helicon Remote

Read more about Helicon Remote here.

Helicon 3D Viewer

Read more about Helicon 3D Viewer here.


 

SHORTCUTS

Below you will find the list of shortcuts used in Helicon Focus. Sometimes using them makes it much more handy to work with images. In order to get used to them we advise you to print out the whole list and to keep it at hand.

Shortcut Description
 
General shortcuts  
 
Ctrl+O Open images
Del Remove images from the Source images list
Page Up, Page Down Navigate through the Source images list
Ctrl+S Save image
Ctrl+R Render the stack
Alt+Ctrl+R Preview
F1 Helicon Focus Help
Right mouse button on slider Reset to default
Alt+Ctrl+Shift+M Folder monitor
F7 Batch process
 
Image navigation shortcuts  
 
Mouse wheel Zoom in/out
Left mouse button Show magnifying glass
Space + Left mouse button Pan the image (hand tool)
Right mouse button Pan the image (hand tool)
Left arrow, right arrow Move the image one step right or left
Ctrl+Left arrow, right arrow Move the image one page right or left
Click on scroll wheel Fit to window/zoom to 100%
 
Retouching shortcuts  
 
[] keys/Ctrl+scroll wheel Adjust brush size
Ctrl+Alt+scroll wheel Adjust brush hardness
Shift+scroll wheel Adjust color tolerance
Alt+scroll wheel Adjust brightness
Ctrl+Z Undo retouching
Ctrl+Y Redo retouching
Right mouse button Set new source area for the Clone brush
Right mouse button Keep it pressed to hide the retouching changes
Ctrl+G Show/hide grid
F9 Load current source image

 

SAMPLES

Click to see the original files.

Helicon Focus 8 User Guide