Lightroom Plugin not working

Shooting in macro mode, techniques, tips & tricks

Moderator: Stas Yatsenko

dkperez
Posts: 46
Joined: 22.03.2014 02:30

Lightroom Plugin not working

Unread postby dkperez » 30.06.2017 21:25

I found a few topics over the last year or so with a similar problem, but they didn't fix whatever it is, so......

Normal PC running Windows 10, 64-bit. Helicon Focus 6.7.1 - it says it's up to date. Adobe Lightroom CC 2015.10.1 - ALSO says it's up to date.

I've never had much luck with the Lightroom Plugin and stopped using it a while ago. But, I currently need to work with several stacks that are in Lightroom so having the plugin work would be useful......

Yes, I've forcibly deleted the whole plugin folder from OUTSIDE Lightroom. And LR showed the plugin gone. And yes, I've gone into the Preferences and said "Install" the plugin, and it came back. And back in Lightroom it says the same thing it's be saying for quite a while:

The plugin HeliconFocus says "Installed but not working". The Path says "c:\Users\David Perez\Appdata\Roaming\Adobe\Lightroom\Modules\HeliconFocus.lrplugin - which is where it appears to be

The Last Message says "An error occurred while attempting to load this plug-in." and Info.lua: bad header in precompiled chunk

------

I've forcibly deleted the plugin. I've uninstalled and re-installed Helicon Focus. Is there just a download JUST of the plugin somewhere with one that doesn't have a "bad header" 'cause it's rather a bother having to wade through thousands of images looking for the right stack at the moment...

dkperez
Posts: 46
Joined: 22.03.2014 02:30

Re: Lightroom Plugin not working

Unread postby dkperez » 01.07.2017 02:41

Since I was using the beta version, I went back and downloaded 6.7.1 again... Got rid of the old one and installed 6.7.1 again... The first installation didn't install the plugin - it created the folder but DIDN'T put the files in. Installed a second time and it got the plugin. Appears to be working.

dkperez
Posts: 46
Joined: 22.03.2014 02:30

Re: Lightroom Plugin not working

Unread postby dkperez » 01.07.2017 14:03

OK, it's sort-of working........

From Lightroom, grab some images to stack, Render, Save, repeat... I don't exit HF between stacks when going from Lightroom any more than I close it every time I open a set of images IN Helicon Focus. After I've done the dozen or so stacks, I'll tell Lightroom to go grab the new files and import them.

SO, half a dozen or so stacks in, Helicon Focus crashes...... Repeatably. Here's the error from the Windows error logs.

Faulting application name: HeliconFocus.exe, version: 6.7.1.0, time stamp: 0x57488308
Faulting module name: ntdll.dll, version: 10.0.14393.479, time stamp: 0x5825887f
Exception code: 0xc0000005
Fault offset: 0x00000000000495dc
Faulting process id: 0x2a6d4
Faulting application start time: 0x01d2f25f0df25886
Faulting application path: C:\Program Files\Helicon Software\Helicon Focus 6\HeliconFocus.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 596d7cb3-39a5-48b4-8685-cedf96713a05
Faulting package full name:
Faulting package-relative application ID:

Now that it's crashed, you can't export any more images to Helicon. Even shutting Lightroom down doesn't bring it back. You can still run Helicon Focus manually, but it's no longer accessible from Lightroom. I suspect I'll have to reboot the whole computer to get it back, which isn't a reasonable thing to do.

I now recall that it's always done this, which is one reason I generally don't use HF from Lightroom - because I have to shut down Helicon after every stack or it'll crash after doing a few.

User avatar
Stas Yatsenko
Posts: 3959
Joined: 06.05.2009 14:05
Contact:

Re: Lightroom Plugin not working

Unread postby Stas Yatsenko » 03.07.2017 14:10

I assume your last post is about Focus 6.7.1. Yes, we know it can be unstable, that's one of the things that the new version is targeting.
On top of that, we know that 6.7.2 had a non-functional LR plugin at first. That is now fixed. Please try the new build of Focus 6.7.2: https://drive.google.com/open?id=0B_uKrE3_LamxaXlVbnRJR1U1bkE


Return to “Helicon Focus: Macro”

Who is online

Users browsing this forum: No registered users and 1 guest