X64 server mode hangs and runs forever

Report bugs and get support here

Moderator: Stas Yatsenko

heljl
Posts: 4
Joined: 07.09.2010 05:53

X64 server mode hangs and runs forever

Unread postby heljl » 07.09.2010 06:07

I'm trying to build stacks using version 5.1.18 x64 and am having trouble. If I run in server mode it starts the x64 server but never completes. The server process runs forever using about a single core worth of CPU. The user interface hangs and displays an hourglass. It is not responsive to Abort or any other command including the close button. I have to kill it from taskmgr. If I disable server mode it is successful. Any suggestions?

I'm running Windows 7 64 bit with dual hex-core processors. Please let know if you would like more information.

User avatar
Stas Yatsenko
Posts: 3958
Joined: 06.05.2009 14:05
Contact:

Re: X64 server mode hangs and runs forever

Unread postby Stas Yatsenko » 07.09.2010 14:06

We have not yet tested the program on this hardware, maybe this your computer is too fast :)
Please upload your stack to our server, we will try to reproduce the bug (as described on http://heliconsoft.com/ftp.html)
Please contact us at support@heliconsoft.com for further details. I would appreciate if you help us to locate this bug.

heljl
Posts: 4
Joined: 07.09.2010 05:53

Re: X64 server mode hangs and runs forever

Unread postby heljl » 07.09.2010 18:43

I uploaded two images. My stack has more but two are enough to cause the problem.

heljl
Posts: 4
Joined: 07.09.2010 05:53

Re: X64 server mode hangs and runs forever

Unread postby heljl » 10.09.2010 09:47

I'm travelling and will test next week. I'll let you know.

My system has 12 real core and 12 more hyperthreaded ones.

Thanks.

heljl
Posts: 4
Joined: 07.09.2010 05:53

Re: X64 server mode hangs and runs forever

Unread postby heljl » 15.09.2010 22:02

I tested using my entire stack and the first (multithreaded) version comlpeted successfully. Thanks for fixing this so fast!

When do you expect to roll this fix into the automatically updated version?

User avatar
Stas Yatsenko
Posts: 3958
Joined: 06.05.2009 14:05
Contact:

Re: X64 server mode hangs and runs forever

Unread postby Stas Yatsenko » 17.09.2010 13:51

Thanks for testing. Version 5.1.19 is already on the server and contains the fixed code.


Return to “Helicon Filter: Bugs and Support”

Who is online

Users browsing this forum: No registered users and 1 guest