Canon 77D / PC connection Problem

General discussions, bugs, support, suggestions
captaindon130
Posts: 6
Joined: 01.06.2018 06:01

Canon 77D / PC connection Problem

Unread post by captaindon130 » 08.06.2018 01:45

I have been trying to connect an iPhone to your software without success so am now trying to connect a Canon 77D DSLR to a Microsoft Surface Pro 4 running Windows 10 Pro. I am going to follow the steps I have seen you suggest to others to save some time.
1. All other camera programs (Canon EOS Utility and other Canon programs) have all been removed from the tablet. Checked that no processes or services are camera related.
2. Started Helicon Remote on the tablet. It said "Camera is not Connected"
3. Cleared all the WiFi settings used to connect with the Canon programs, which worked as advertised. The LCD on the top of the camera shows a dark WiFi icon and the label "Off". Enabled the WiFi - display did not change. Registered a name (default EOS77D) - no display change. Under "WiFi function"selected "Remote Control (EOS Utility) - no display change. Asked to register a device - camera started its WiFi network and the display showed "ON" and the icon was blinking.
4. Used Windows settings to connect to the camera network - using password provided by camera.
5. Camera asked to pair and tried Pairing asking for the EOS Utility to be started.
6. Restarted Helicon Remote and under "Tools" selected "network cameras". No network camera showed up in the following dialog box. Display shows WiFi is on and the Dark icon is blinking.
7. Waited five minutes with no change so I tried the same process selecting "Smartphone" starting with step 3.
8. Disabled the WiFi, cleared all settings and cycled power on the camera. Had to make the camera tablet connection via Windows O/S again. Using the "Smartphone" option did not make a difference. The camera and application would not connect.

Any help would be appreciated thanks.

User avatar
Stas Yatsenko
Posts: 3617
Joined: 06.05.2009 14:05
Contact:

Re: Canon 77D / PC connection Problem

Unread post by Stas Yatsenko » 10.06.2018 16:46

The sequence you described is very similar to the right thing, but slightly off. Specifically, in the paragraph 6.
First, it's best to launch Helicon Remote before connecting the camera. Usually it makes no difference, but when something doesn't work it's the more reliable way.
And most importantly, "Tools" -> "Network cameras" lists the camera entries that you've added manually. You only ever need it when the camera is not detected automatically and you have to specify it's IP address manually. It sometimes can happen for a number of reasons, but you shouldn't be hitting this issue. Hence, you have no need for the "Network cameras" functionality. Instead, look for the camera under "Select a camera" button on the "Camera settings" panel of the main window.

Post Reply