Page 1 of 1

Wireless tethering with Canon 5D-MK4?

Posted: 30.12.2017 00:40
by esparks
Hello...

Has anyone tethered a Canon 5D-MK4 to Helicon Remote successfully using the camera's built-in WiFi capability? Helicon Remote will not recognize the camera when connected to the PC in either the Ad-Hoc or Infrastructure wireless modes. Adding the camera's IP address manually does not change the symptom.

The Canon EOS utility will connect to and control the camera successfully in either type of wireless connection. Helicon Remote works as expected when the camera is connect to the PC via USB.

When the PC is connected wirelessly, I can ping the camera successfully and have confirmed that the Helicon firewall rules for TCP and UDP are in place and enabled. I can also observe outbound TCP traffic from the camera on the correct port, and see an acknowledgments from the PC -- but still no joy.

I'm about out of troubleshooting ideas. Can anyone from Helicon confirm that the 5D-MK4 was tested successfully with a wireless connection?

Windows 10 Pro
Helicon Remote v3.9.1 W
Canon firmware v1.0.4

Thanks for your help...
Ed

Re: Wireless tethering with Canon 5D-MK4?

Posted: 03.01.2018 15:36
by Stas Yatsenko
It could be that the system is simply misconfigured in some way. For instance, you have to be certain the IP address is correct when you're adding the camera entry manually. On the other hand, if you did add it correctly, then Helicon Remote has no choice but to connect to the camera. What message are you getting when clicking this entry under "Select a camera"? Is it "No device with such address found", or "Camera refused connection"?
If it's the former, then my next question is whether you have more than one network adapter on your computer. If you do, that is likely why it doesn't work.