Disconnect the wrong way

General discussions, bugs, support, suggestions
Post Reply
paliswe
Posts: 1
Joined: 25.12.2016 18:59

Disconnect the wrong way

Post by paliswe » 25.12.2016 19:28

Helicon-remote version 3.8.0
Samsung 10.1 SM-P600 pad, Android version 5.1.1.
Nikon D7200

When Helicon Remote is opened and shows live-view, everything works fine. When the connection is broken, either by disconnected cable or camera switched off while in live view, the Helicon Remote hangs. Trying to exit the program results in nothing, after a while I manage to stop the program by forcing it to stop. If I wait long enough the Android-OS tells me that the program is not answering, ”shall I quit it?” Yes, please, and it closes.
When started again it will not connect to camera. Even if I open the control program and forces a stop för the Helicon app, nothing works.
I have to reboot the Samsung pad to get everything working again.

Now I have learned that I have to exit the Helicon program before switching off the camera. But Helicon Remote for Android should be more ”fool-proof” than that.
Open and closing the program without any camera connected from the beginning works fine.

Regards, Paliswe

User avatar
Stas Yatsenko
Posts: 3850
Joined: 06.05.2009 14:05
Contact:

Re: Disconnect the wrong way

Post by Stas Yatsenko » 26.12.2016 14:00

Thanks for the information, we'll keep this in mind. Right now it's unclear how is it possible. We do regularly disconnect and reconnect the camera while the app is running, it's supposed to cause no problems.

CraigF
Posts: 2
Joined: 02.02.2017 22:35

Re: Disconnect the wrong way

Post by CraigF » 02.02.2017 22:43

Hi Stas, For what it's worth I have a similar problem on a Mac. I can't figure out the correct combination for quitting the program without it hanging up. Currently I turn off live view, quit Remote and then turn off the camera. Sometimes that works and sometime not. If I don't quit in that sequence Remote hangs almost every time I quit and it will not force quit. Yesterday I had to hard power down the computer to get it to quit.

Early 2008 Mac Pro 10.11.6 and Canon 5DSr via USB 3.0 (PCI card added to the Mac)

User avatar
Stas Yatsenko
Posts: 3850
Joined: 06.05.2009 14:05
Contact:

Re: Disconnect the wrong way

Post by Stas Yatsenko » 03.02.2017 16:40

Could there be another camera-related program running at the same time? If there is such a program, it could well be the culprit.

CraigF
Posts: 2
Joined: 02.02.2017 22:35

Re: Disconnect the wrong way

Post by CraigF » 03.02.2017 20:08

Stas Yatsenko wrote:Could there be another camera-related program running at the same time? If there is such a program, it could well be the culprit.
Thank you, Stas. I think that was the issue. EOS Utility was in the start up items list. It didn't actually start up in the full sense but I guess it was running in the background. I removed it and so far Remote seems to be quitting properly.

Apologies to the OP, Paliswe for hijacking the thread.

Best,
Craig

Post Reply