6.7.2 crashing constantly, need an older version asap

Announcement of new releases, bugs, support, suggestions

Moderator: Stas Yatsenko

bo2909
Posts: 2
Joined: 23.05.2018 13:23

6.7.2 crashing constantly, need an older version asap

Unread post by bo2909 » 23.05.2018 14:07

Hi there,
Since the upgrade helicon focus is strangely crashing all the time.
Would like to be able to get an older version, which was working fine before.
Is this possible?

I always keep the older versions of softs, in case, but now I forgot since I activated the update from the soft itself...

Thank you for any help!
B.

BobStone
Posts: 13
Joined: 03.06.2017 10:13

Re: 6.7.2 crashing constantly, need an older version asap

Unread post by BobStone » 23.05.2018 20:05

You might try the latest version which is 6.8.0 ….

User avatar
Stas Yatsenko
Posts: 3534
Joined: 06.05.2009 14:05
Contact:

Re: 6.7.2 crashing constantly, need an older version asap

Unread post by Stas Yatsenko » 23.05.2018 21:09

Please contact us via support@heliconsoft.com. We will send you a link to new beta version.

bo2909
Posts: 2
Joined: 23.05.2018 13:23

Re: 6.7.2 crashing constantly, need an older version asap

Unread post by bo2909 » 25.05.2018 12:22

Well I only see 6.7.2 available on the website for Mac OS, it is rather strange that Helicon Focus does not keep available on their website previous versions of the software. Also because not everyone has the latest OS.
I use also Capture One as part of my workflow, and they do propose older versions of their software, which is quite smart, you never know which technical problems a new version can cause.

It is a bit tricky and annoying to have to wait hours to get a solution on such simple problems caused by an update, professionnally speaking I mean.
I really like Helicon Focus though, but yes I'd like to be able to count on it.
Thanks

Locked