HF 7.0.0 Mac Beta testing, part one: Alignment problem

Announcement of new releases, bugs, support, suggestions

Moderator: Stas Yatsenko

Post Reply
sbuerger
Posts: 23
Joined: 05.06.2010 15:31

HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by sbuerger » 02.04.2018 20:10

Hi Stas,
finally, here comes part one of my testing results. Originally I planned on starting a single thread on beta testing, but when I stumbled across the problem described below I felt like it deserves an own thread.

The other day I started a DOF test stack with a microscope objective. Object was a plain piece of black cardboard in a diagonal angle to the optical axis. The (correct) rendered result from HF 6.8.0 looks like this:
1-10x,5um_HF68_kl.jpg
1-10x,5um_HF68_kl.jpg (174.18 KiB) Viewed 1804 times
However, if I render the very same stack with the very same settings in HF 7.0.0, it looks like this:

(see attachments below)

In both cases I used method C - I also tried methods A and B with basically the same scaling error. Next, I tried to modify the alignment settings which initially had been standard in both HF versions (V 3%, H3%, rotate 0°, scale 5%). I found out that if, in HF 7.0.0, I set the "scale" value to zero, the result turns out fine, just like the 6.8.0 output (keep in mind, I used an infinite microscope objective with an approximately telecentric behavior - I would not recommend using a zero value with a macro lens...). If I set the value to 1%, I already get a misscaled/misaligned result, and the higher a value I set, the stronger the misalignment gets.

Next thing I tried was using alignment settings 3%,3%,0°,5% again but additionally checking "Manual detection focus area adjustment" - just to see what happens; as yet I don't have a clear idea of what this setting does. This did not give me any additional options (as I had assumed because it's "manual"), but the rendering result looked dramatically difficult:

(see attachments below)

This result is not correct (pictures that were erroneously scaled up without "Manual detection" are now scaled down a bit, and there is some misalignment visible in details), but obviously aligning is done in a very different way.

I tried the same object with a 4x objective (examples above are 10x) with the same strange results, so I think the problem is, partially, object specific. After doing about a hundred stacks in 7.0.0, this was the first one showing such a strange effect, and the object is quite different from what I usually have (wouldn't take an object as boring as this, if not for DOF testing purposes). Nevertheless, since HF 6.8.0 did not have the least problem with the stack at default settings, there must be something working correctly in the old version that isn't in the new one.

I uploaded the stack to your FTP server (Stephan_misalignment.zip), so you can use it for testing.

Oh, and last but not least: The HF version I use is still 7.0.0 from Jan 15, 2018. Maybe meanwhile there is a newer build? If so, of course I would like to try that - quite likely the other issues I found (which are mainly GUI specific) are already resolved.

Kind regards
Stephan

sbuerger
Posts: 23
Joined: 05.06.2010 15:31

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by sbuerger » 02.04.2018 20:19

Grrr...you know it's a pain to attach images in this forum? So, here's the picture that should have showed second in the above posting (HF 7.0.0 with default settings):
Attachments
2-10x,5um_HF70_kl.jpg
2-10x,5um_HF70_kl.jpg (302.8 KiB) Viewed 1804 times

sbuerger
Posts: 23
Joined: 05.06.2010 15:31

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by sbuerger » 02.04.2018 20:25

And here's the third one (HF 7.0.0 with "Manual detection focus area adjustment"):
Attachments
3-10x,5um_HF70,MFD_kl.jpg
3-10x,5um_HF70,MFD_kl.jpg (169.73 KiB) Viewed 1804 times

User avatar
Stas Yatsenko
Posts: 3711
Joined: 06.05.2009 14:05
Contact:

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by Stas Yatsenko » 04.04.2018 15:37

Thanks for the stack. You are right, new version does not align images correctly. It looks like this happens because focused area is so small compared to whole image. We recommend to decrease max scale adjustment to 1% in Autoadjustment tab in preferences. Please also note that images are shot not in consecutive order. Focus moves forward, then moves backward. Method B requires images to be shot in the same order

sbuerger
Posts: 23
Joined: 05.06.2010 15:31

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by sbuerger » 04.04.2018 21:57

Stas,
as I said, I used method C (also tried A and B with comparable results) - but anyway, the images are indeed shot in consecutive order. As you can see in the MP4 I supplied with the stack, the rail wobbles a bit in the first few frames (which, annoyingly, can't be avoided with Stackshot at 10x magnification), but apart from the image field (which shifts to the right) the focus area moves in even steps and only in forward direction.
Nevertheless, the wobbling was my #1 suspect, too - but if you process a stack without the first 20 or so frames (in which the wobbling takes place), the result gets no better, so obviously it is not what confuses the program.

As I also said before: Even if I set the scale adjustment value to 1%, I already get a misscaled/misaligned result, and the higher a value I set, the stronger the misalignment gets. The only way to get a result that looks like that of HF 6.8.0 is to set scale adjustment to 0% - it seems that whatever scaling factor I allow, will be exactly be what the program uses per step (try 20% for a really strange result).

To avoid misunderstanding, I myself do not need a solution for this special stack - using 0% scale adjustment or HF 6.8.0 does the job. The question is just if problems like this might occur in more relevant situations (and if they might be avoided without sacrificing HF 7.0.0's speed gain, regarding that HF 6.8.0 is slower, but more robust in this respect). The small size of the focused areas is something that is quite usual with microscopic stacks due to low DOF - the constant and continuous steep angle of the object surface (resulting in the "straight strips" of focus area), on the other hand, is not. I never experienced any such problems with HF 7.0.0 in "regular" object situations, be it macro or micro.

BTW, please don't forget the last question in my initial posting:
>Oh, and last but not least: The HF version I use is still 7.0.0 from Jan 15, 2018.
>Maybe meanwhile there is a newer build? If so, of course I would like to try that -
>quite likely the other issues I found (which are mainly GUI specific) are already
>resolved.
PM or email answer is welcome too, of course. ;)

Kind regards
Stephan

User avatar
Stas Yatsenko
Posts: 3711
Joined: 06.05.2009 14:05
Contact:

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by Stas Yatsenko » 05.04.2018 14:44

We sent you a link to new Beta version in a private message, I would appreciate if you check it.

Alnitak
Posts: 1
Joined: 15.04.2018 16:23

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by Alnitak » 15.04.2018 16:28

As a Mac user, I'd love to participate in any beta testing on the new version. Can I get a link? Any plans on integrating support for the WeMacro in the new Mac version of Helicon Remote (assuming that is also being updated)?

User avatar
Stas Yatsenko
Posts: 3711
Joined: 06.05.2009 14:05
Contact:

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by Stas Yatsenko » 16.04.2018 11:51

Sure, link sent in a PM.
Wemacro is supported by the latest version of Helicon Remote on our website (3.9.2).

joceyp
Posts: 2
Joined: 01.05.2018 18:10

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by joceyp » 01.05.2018 18:44

I know this is a couple weeks behind but I am also having an issue with HF 7.0 stacking incorrectly and misaligning. I sent an email to customer support today directly because the Contact page on the website wasn't working but I haven't gotten a response yet and I'm starting to get flustered as I can't complete jobs now.
I'm currently using version 7.0 for Mac, dated Jan 15 2018. I attempted revert back to the most current version for Mac listed on the website (6.7.2) and that application has crashed on me 20 times without even opening now, so I'm a bit stuck as I can't use either version. Can I possibly get an updated 7.0 or please advise how to get 6.7.2 to run?

User avatar
Stas Yatsenko
Posts: 3711
Joined: 06.05.2009 14:05
Contact:

Re: HF 7.0.0 Mac Beta testing, part one: Alignment problem

Post by Stas Yatsenko » 02.05.2018 14:08

Based on how many e-mails we're receiving every day, I don't think there was a problem with our contact page. Could have been something on your end. Also, I've looked and didn't find any e-mails from the address you've registered on the forum with (but you might have used a different address).
Anyway, we have a new version of Helicon Focus 7.0 (link sent in a private message), please try it out and contact us if there are any problems.

Post Reply