Trouble with -i parameter in CMD line mode

Announcement of new releases, bugs, support, suggestions
Post Reply
sheimend
Posts: 9
Joined: 17.07.2016 23:21

Trouble with -i parameter in CMD line mode

Post by sheimend » 16.08.2016 04:55

I've built a few scripts to help with my massive batch processing of image stacks using the command line mode of Helicon. It's a lifesaver! As soon as I've added a little extra validation to my scripts, I'd be happy to share them with the community.

I'm having trouble with the "-i" parameter. My understanding is that, if I don't want to stack an entire folder, I can create a text file where each line is a file name and pass this file to HeliconFocus.exe with the -i parameter.

My PowerShell script builds a text file with the input file names on each line. (I can't seem to attach my txt file to this post, but) The file contents are:

Code: Select all

E:\My Projects\Sequential\file-0001.CR2
E:\My Projects\Sequential\file-1201.CR2
E:\My Projects\Sequential\file-2401.CR2
I'm saving this file as E:\temp.txt. I've ensured that the file is being written correctly and is closed and available for reading.

I'm calling Helicon using the following syntax:

Code: Select all

E:\Program Files\Helicon Software\Helicon Focus 6\HeliconFocus.exe -silent -i "E:\temp.txt" -save:"E:\My Projects\Stacked\filename.dng" -mp:0
But, when I do, I get a Helicon Focus dialog warning box that says, "No source files found at path: E:\temp.txt".

I've tried putting quotes around the file names in my text file, I've tried putting them all on one line with a "\n" between them, but I always get the same error.

What am I doing wrong?

Thanks so much in advance for your help!
-Scott

User avatar
Stas Yatsenko
Posts: 3850
Joined: 06.05.2009 14:05
Contact:

Re: Trouble with -i parameter in CMD line mode

Post by Stas Yatsenko » 16.08.2016 16:37

At the moment, "-i" cannot be combined with "-silent". In other words, you can only specify folders in the command line mode, not lists of files.
We're looking into it.

sheimend
Posts: 9
Joined: 17.07.2016 23:21

Re: Trouble with -i parameter in CMD line mode

Post by sheimend » 16.08.2016 17:13

Thanks very much for the quick response. Unfortunately, my scenario requires the "-silent" mode, so I suppose I'll need to continue pre-grouping my shots by folder for now. I'd love to be able to pass in file names directly, or via a text file with the -i parameter so I can programatically create variations of stacking sequences.

Thanks, as always, for your timely reply and for your help! Fingers crossed that this option makes it into an upcoming build!


Post Reply