D5000 problems

Announcement of new releases, bugs, support, suggestions
Post Reply
Bluesman2008

D5000 problems

Post by Bluesman2008 » 25.12.2009 04:23

D5000 Several months ago after being away from film photography for decades, I picked up the entry level D40. So far so good. Great pictures. Easy to use. But I'm also into computer graphics.

I happened upon a piece of software for macro photography that blew me away. It's called Helicon Focus. In short, it takes several macro shots at different focus points and then combines them into one final image where the whole range is in sharp focus. Check out the demo on their site. It'll knock your socks off.

Well, the software ALSO will (through the USB cable) focus and shoot the camera for you and get whatever it needs and then creates the final shot. BUT, it only works with cameras with LiveView. You can guess where I'm going with this, right?

So I trot down to my local cameral store and after being disappointed as hell in what they offered on a trade in for a D5000 ($100 bucks) I luckily ran into a mother and her daughter who happened to be looking for just that camera (D40) so I got $250 for it (the store sold them used for $399 so the mom and daughter were thrilled (mine was only months old and in perfect condition).

So I get the D5000, install the software and the PC will NOT communicate with the camera. When I plug in the USB cable and turn on the camera, the little bubble pops up showing the device is loaded. But Nikon transfer will NOT automatically load as it's supposed to and, although the D5000 DOES show up in the device manager, the software won't read it and explorer won't show it as an external drive (as it did for my D40) or any USB drive, for that matter.

I've been online with Dell tech support for nearly 8 hours over two days and tomorrow I start with the hardware guys because the software guys wore me out after picking and poking and tweaking my OS and still can't get the damned thing to work. They uninstalled my firewall and a couple of bug cleaners (Malwarebytes, etc.) but still nothing.

Sure if I put the mem card from the camera into a card reader, I can transfer everything to the PC (Dell XPS 625 with XP Pro SP3) I can then view/edit it, BUT my lovely Helicon Focus won't work and the PC still doesn't recognize it as a drive.

I called Nikon and they ran me through the same stuff as Dell (you know the routine....plug it into a different USB port, turn off the power, reboot, ten hail marys, the usual BS. I consider myself a fairly adept power use and I've done all the usual stuff for hours long before calling anyone.

The first thing out of the Nikon tech was "what kind of card are you using"? I said "uh, the one that came with the camera" (not SanDisk or anything I recognized) but It sure lets the cam take and store pictures. BUT, since I assume he knows more than I do about his cameras, I trot back to the store and buy a (much more expensive) SanDIsk (8gb) and that solved nothing.

Next they ask me to create a system report and forward it to them. I do that and, after analyzing it, they tell me nothing is wrong. BS. There IS something wrong because it's not working (not only Helicon but the Nikon transfer software and it's still not being recognized as an external drive as it's supposed to.

Well, I did a Windows file check (SFC) and upgraded the BIOS and every imaginable driver and still nothing. If anyone has had a similar problem and found a solutions, I would LOVE to know what it is. I've done everything I can think of short of a rain dance.

One of the Dell techs said that if nothing else worked, the best thing to do is wipe the drive and reinstall the OS. I told him that it would take me a week to reinstall all the software I use and would much prefer deep root canal than wipe and reinstall. I've done a wipe and reinstall twice after a serious trojans snuck in and it's the last thing I want to do again.

Any suggestions will not only be greatly appreciated, but will prevent me from tearing what little hair I have left out of my head. I hate it when new stuff doesn't work. Any help greatly appreciated.

Oh, I also went back to the store and exchanged the D5000 for another new one thinking the camera itself might be the problem and the same thing happened so there's something rotten in Denmark and damned if I can figure out what.

I've only had the D5000 for a couple of days but, as far as picture taking, I really like it a lot. I like the LIveView and the video quality was MUCH better than I expected and, of course, the swing-out viewer is handy as hell. Of course it's manual focus time for that since AF ain't happening but other than that, I really like the camera.

User avatar
Stas Yatsenko
Posts: 3850
Joined: 06.05.2009 14:05
Contact:

Re: D5000 problems

Post by Stas Yatsenko » 05.01.2010 15:10

We checked the Nikon modules that come with Helicon Remote and D5000 should be supported. D90 is working file though it also supports only PTP connection. We will fix this problem as soon as we have D5000 for tests in our office.

Howard
Posts: 12
Joined: 15.01.2010 12:27

Re: D5000 problems

Post by Howard » 21.01.2010 09:59

Were you able to check the D5000 yet? Still not working. This software is useless to me without the remote utility working. I can get free stacking software (Zerene, CombineZP, etc.). The only reason I purchased this software is because I was given to believe the only requirement for the camera was having Live View. Mine does.

User avatar
Stas Yatsenko
Posts: 3850
Joined: 06.05.2009 14:05
Contact:

Re: D5000 problems

Post by Stas Yatsenko » 21.01.2010 18:06

We will send you debug version to gather more information about this error. I would appreciate your help.

Howard
Posts: 12
Joined: 15.01.2010 12:27

Re: D5000 problems

Post by Howard » 24.01.2010 03:49

Glad to help. Awaiting the debug program.

User avatar
Stas Yatsenko
Posts: 3850
Joined: 06.05.2009 14:05
Contact:

Re: D5000 problems

Post by Stas Yatsenko » 26.01.2010 19:22

Please unzip this file http://www.heliconsoft.com/downloads/HeliconRemote.zip into the current Helicon Focus folder, then run Helicon Remote. Please open Prefernces\Tools and send us current log.

Howard
Posts: 12
Joined: 15.01.2010 12:27

Re: D5000 problems

Post by Howard » 20.03.2010 23:48

This is the log file created. But as soon as I created it, remote crashed and I had to ctrl-alt-del to shut it down.

(4529.324219) Version of library remoteControl: 1.0.5(3.03.2010)
(0.158203) OS Microsoft Windows XP Professional Service Pack 3 (build2600)
(0.125000) Start 20.03.2010 13:31:41
(0.062012) CSdkBase: creating
(0.048340) CSdkBase: create all SDK, begin
(0.050781) CCanonSdk: creating session
(39.844727) CCanonSdk: created
(0.114746) CNikonSdk: creating
(0.049805) CNikonSdk: findModule, begin
(0.052246) CNikonSdk: findModule, end, (D200_Mod.md3)
(0.050781) CNikonSdk: loadModule, begin
(2.507324) CNikonSdk: findModule, end
(0.128418) CNikonSdk: openModule, begin
(149.819824) CNikonSdk: openModule, end
(0.161133) CNikonSdk: created
(0.052246) CNikonSdk: creating
(0.042480) CNikonSdk: findModule, begin
(0.044922) CNikonSdk: findModule, end, (Type0001.md3)
(0.040527) CNikonSdk: loadModule, begin
(2.788086) CNikonSdk: findModule, end
(0.082520) CNikonSdk: openModule, begin
(133.532715) CNikonSdk: openModule, end
(0.086914) CNikonSdk: created
(0.051758) CNikonSdk: creating
(0.041992) CNikonSdk: findModule, begin
(0.045410) CNikonSdk: findModule, end, (Type0002.md3)
(0.042969) CNikonSdk: loadModule, begin
(2.843262) CNikonSdk: findModule, end
(0.084961) CNikonSdk: openModule, begin
(128.145020) CNikonSdk: openModule, end
(0.090332) CNikonSdk: created
(0.047852) CNikonSdk: creating
(0.040527) CNikonSdk: findModule, begin
(0.041992) CNikonSdk: findModule, end, (D40_Mod.md3)
(0.039063) CNikonSdk: loadModule, begin
(2.827637) CNikonSdk: findModule, end
(0.081543) CNikonSdk: openModule, begin
(143.433105) CNikonSdk: openModule, end
(0.082031) CNikonSdk: created
(0.049805) CNikonSdk: creating
(0.044434) CNikonSdk: findModule, begin
(0.044922) CNikonSdk: findModule, end, (D80_Mod.md3)
(0.039551) CNikonSdk: loadModule, begin
(2.318848) CNikonSdk: findModule, end
(0.081543) CNikonSdk: openModule, begin
(166.445313) CNikonSdk: openModule, end
(0.097168) CNikonSdk: created
(0.052734) CNikonSdk: creating
(0.043457) CNikonSdk: findModule, begin
(0.045410) CNikonSdk: findModule, end, (Type0003.md3)
(0.041504) CNikonSdk: loadModule, begin
(3.104004) CNikonSdk: findModule, end
(0.085938) CNikonSdk: openModule, begin
(194.239746) CNikonSdk: openModule, end
(0.083496) CNikonSdk: created
(0.050293) CSdkBase: create all SDK, end
(0.044922) CSdkBase: created

Post Reply