Output switching is super slow again

Announcement of new releases, bugs, support, suggestions

Moderator: Stas Yatsenko

Post Reply
User avatar
brucek
Posts: 13
Joined: 21.11.2016 22:23

Output switching is super slow again

Post by brucek » 15.11.2018 01:27

Hi Stas,
I originally reported this in Helicon Focus 6.7, and it went away for a while in 7.0, but the problem is back.
Helicon Focus 7.02 pro
Windows 10 Pro, 1803, 64-bit
Intel Core i7-4770K @ 3.50 GHz
32 GB RAM

Switching between outputs in Helicon Focus has slowed down drastically for me. Selecting a different output or frame after a render used to take at most a few seconds, but now takes at least 3 minutes, sometimes a lot more. I get the blue spinny hourglass pointer and the window title says "Not responding." Other programs, including Lightroom are working normally.

I have plenty of ram and the program is barely touching it (currently 8.7 GB of the 32 with a 105 (4256 x 2832) frame stack and two renders loaded. The 8 threads of the processor are not taxed at all and Helicon is not even breaking 1% cpu utilization during this time. I have lots of disk space available. This happens on short stacks of only a few dozen as well as larger 200 frame stacks. The one thing that IS slow on this machine is my internet access, which is currently extremely limited, but I can't imagine Helicon should care about that.

I have not experimented with different startup scenarios, but I'm starting from the Lightroom export plugin.

I did try to "wipe" the settings, but there was no improvement.

Is there something that can get messed up in the configuration to cause this slowdown? Any known issues with recent Windows updates? Suggestions for debugging or improving this? It is making Helicon Focus next to unusable for me.

User avatar
Stas Yatsenko
Posts: 3712
Joined: 06.05.2009 14:05
Contact:

Re: Output switching is super slow again

Post by Stas Yatsenko » 16.11.2018 15:46

Thanks for reporting this bug. Last time it was caused by Exif library and we believed that we fixed it. Maybe it different but similar problem. Can you send us source stack to reproduce the bug?

User avatar
brucek
Posts: 13
Joined: 21.11.2016 22:23

Re: Output switching is super slow again

Post by brucek » 17.11.2018 10:11

My internet is way too band limited to send this 105 image source stack (I live on an island and only have cell service for internet), but I'll see if I can come up with a small test case that shows the problem in the next couple of days.

User avatar
brucek
Posts: 13
Joined: 21.11.2016 22:23

Re: Output switching is super slow again

Post by brucek » 18.11.2018 22:26

I narrowed it down to a minimum stack of 2 and the issue is still there. I've uploaded a zip of the two frames, as exported by Lightroom, to my dropbox:
https://www.dropbox.com/s/4v31qek3aq91h2l/exif_slowdown_test.zip?dl=0
Let me know when you have it so I can clear the space on my dropbox.

User avatar
Stas Yatsenko
Posts: 3712
Joined: 06.05.2009 14:05
Contact:

Re: Output switching is super slow again

Post by Stas Yatsenko » 20.11.2018 16:53

Here is the link to zip files with a pair of tiffs without EXIF: https://www.heliconsoft.com/downloads/NoEXIF.zip

Please check this stack and let us know if it behaves differently from your original tiffs. Secondly, to check if internet connection is a reason for slow down, disable internet access altogether. The program usually only checks activation once per session, so this should not be a problem.

User avatar
brucek
Posts: 13
Joined: 21.11.2016 22:23

Re: Output switching is super slow again

Post by brucek » 22.11.2018 03:28

Your stack with exif data removed misbehaves in the same way when my slow internet is enabled.

When I disabled wifi and restarted Helicon, rendering the Method A stack showed 50% on the progress bar for 6 minutes. After that, the progress bar disappeared, but the pointer icon still had spinny (hourglass) for another two minutes. The output icon never appeared on the bottom of the screen like it normally does, so I couldn't switch between outputs.

User avatar
Stas Yatsenko
Posts: 3712
Joined: 06.05.2009 14:05
Contact:

Re: Output switching is super slow again

Post by Stas Yatsenko » 22.11.2018 14:50

We can't reproduce this bug, so you will need to make more tests yourseft. I would suggest to do the following:
1. Uninstall Helicon Focus. Delete "c:\Program Files\Helicon Software" and install it again.
2. Make sure that your CPU does not overheat. Use CPU-Z or similar utility to monitor its temperature.
3. Convert your stack to JPEGs, see if image format makes any difference.
4. Run Preferences\Performance\Run benchmark and compare performance of your system with similar CPUs.
5. Run the same stack with different methods and several time to see any pattern in slowdowns

User avatar
brucek
Posts: 13
Joined: 21.11.2016 22:23

Re: Output switching is super slow again

Post by brucek » 24.11.2018 22:03

I uninstalled all Helicon software and reinstalled. The bug is gone.
One thing that caught my attention: There was still an old 6.8 version of Helicon Focus installed alongside the 7.2. I had assumed that 7.2's installation would upgrade in place, so I didn't bother to uninstall that. Maybe there were some crossed links or something? Anyway, it's fixed for now. I'll let you know if it regresses.
(CPU temp during stacking only hits 37C, so that wouldn't be the culprit.)

User avatar
Stas Yatsenko
Posts: 3712
Joined: 06.05.2009 14:05
Contact:

Re: Output switching is super slow again

Post by Stas Yatsenko » 26.11.2018 16:59

I am glad it solved the problem, keep us informed if it appears again. Theoretically, two version should interfere with each other.

Post Reply